Jump to content

Custom Search



Welcome to Ford Fusion Energi Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Fusion Energi Forum. You must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of the Ford Fusion Energi Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album, post images and more. . .
Click here to create an account now
 
Guest Message by DevFuse

Love your Fusion Energi? Register it in the official authorized Ford Energi Registry here.


Photo
- - - - -

Anyone else lose a quadrant on their charge ring?


  • Please log in to reply
35 replies to this topic

#21 OFFLINE   Eric4539

Eric4539

    New Member

  • Fusion Energi Member
  • 391 posts
  • Region:U.S. Pacific Coast
  • LocationCentral Valley
  • Current Vehicle:2013 Fusion Energi Titanium
  • My Fusion's Year:2013

Posted 02 April 2016 - 08:30 PM

I just had my 2nd charge port ring replaced. Back in July 2014 it was the 1st quadrant that was out. This time it was the 4th quadrant. I picked my car up from the dealer after they replaced the A and B pillar pieces that they scratched in completing the door latch recall. The light ring was out when I went to get my car.

Ginger Ale Energi Titanium

Purchased 6/29/13 from dealer inventory

Moonroof

Driver Assist Package

Adaptive Cruise Control

Navigation

Active Park Assist

All Weather Floor Mats

Cargo Net









Lose this advertisement by becoming a member. Click here to create a free account.


#22 OFFLINE   CombsAuthor

CombsAuthor

    New Member

  • Fusion Energi Member
  • 115 posts
  • Region:U.S. Southern Plains
  • LocationTX
  • Current Vehicle:2013 Ford Fusion Energi Hybrid

Posted 30 June 2016 - 08:33 PM

My fourth quadrant is out now too. It's yet to go to the dealer for any problems...so I guess it's about time.

#23 OFFLINE   kellerb

kellerb

    New Member

  • Fusion Energi Member
  • 2 posts
  • Region:U.S. Mountain
  • LocationArizona
  • Current Vehicle:Fusion Energi Titanium
  • My Fusion's Year:2014

Posted 19 July 2016 - 04:22 PM

I lost the 2nd and 4th quads.  Took it to the dealership and it started working.  Monitored it for 6 months, until they stayed off consistently.  The ring is either made up of incandescent light filaments or, poorly manufactured, based on all the feedback I've read here.

The dealership did, after the second trip, order the part and replace free of charge.

Unfortunately, I didn't notice for a couple of weeks, but there is a very slight ding next to the light ring.  I suspect the technician did this while replacing the light ring.   As I said, it is very minor.



#24 OFFLINE   gladeplugin

gladeplugin

    New Member

  • Fusion Energi Member
  • 21 posts
  • Region:U.S. Southern
  • LocationSouth Central
  • Current Vehicle:ford
  • My Fusion's Year:2013

Posted 25 August 2016 - 07:52 AM

Same here. First quadrant does not illuminate when charged. Also does not illuminate when it cycles upon first connection.


2013 Fusion Energi Ti:

Adaptive Cruise

40A OpenEVSE

Philips LED H11 fog lights

Starnill LED H11 and H7 headlight


#25 OFFLINE   paulsen68

paulsen68

    New Member

  • Fusion Energi Member
  • 6 posts
  • Region:U.S. Mississippi Valley
  • LocationWisconsin
  • Current Vehicle:Ford Fusion Energi
  • My Fusion's Year:2013

Posted 26 August 2016 - 03:41 AM

I just had mine in to the dealership for this issue and it ended up being a bad module, not the ring itself.  They did some tests and then had to get ahold of the Ford engineers to figure it out but now it is fixed and I have a fully functioning ring!



#26 OFFLINE   miamiyogi

miamiyogi

    New Member

  • Fusion Energi Member
  • 1 posts
  • Region:U.S. Southern
  • LocationMiami, Florida USA
  • Current Vehicle:Ford Fusion Energi
  • My Fusion's Year:2014

Posted 26 August 2016 - 12:46 PM

So I just bought my Fusion Energi (Used). And the charging ring worked the first time I charged it. It rained the following night, and I can tell it has something to do with the water, because its water logged inside the light ring at the bottom. When it dries out the third quadrant wants to light up. It flickers. First quadrant is dead. Car is still under 3 year bumper to bumper....but I am hesitant to take it to the dealer because it is our only car and if they take it in for a week I'll have to rent a car at $25+/- a day. I can't justify that expense for what really is a cosmetic issue. 

 

I am mildly annoyed at it though because I like the look of the ring when I unlock it...it influenced my purchase a little. 

 

First time poster here so cheers! I've been lurking for two weeks. 



#27 OFFLINE   My14Energi

My14Energi

    New Member

  • Fusion Energi Member
  • 102 posts
  • Region:Decline
  • LocationFlorida
  • Current Vehicle:Fusion Energi
  • My Fusion's Year:Decline

Posted 27 August 2016 - 04:03 PM

That seems like a crap reason to not get be able to get a car fixed while under warranty. I got mine CPO which includes a rental, i also just came over to Ford from owning a Lincoln for the last 10 years which they always gave a free loaner if your repair was more than one day. Ford should have a little more respect for their owners.

Edited by My14Energi, 27 August 2016 - 04:05 PM.


#28 OFFLINE   dgwillim

dgwillim

    New Member

  • Fusion Energi Member
  • 4 posts
  • Region:U.S. Pacific Coast
  • LocationPhoenix, AZ
  • Current Vehicle:Ford Fusion Energi Titanium
  • My Fusion's Year:2014

Posted 09 September 2016 - 11:17 AM

I have a 2014 Fusion Energi Ti. Purchased new, off the lot, in 2014.

Just lost the bottom right (3rd) quadrant.

 

I'm currently at 34k, so the ring is being replaced under the original 3y/36k warranty.

I wonder if the ESP plan will cover future charge ring failures.


2016 Zero SR 13.0 w/ PowerTank - 2014 Ford Fusion Energi Ti - 2002 Toyota Tundra SR5


#29 OFFLINE   bwheetley

bwheetley

    New Member

  • Fusion Energi Member
  • 35 posts
  • Region:U.S. Southern
  • LocationAtlanta, GA
  • Current Vehicle:Fusion Energi
  • My Fusion's Year:2014

Posted 10 September 2016 - 04:45 PM

I have a 2014 Fusion Energi Ti. Purchased new, off the lot, in 2014.

Just lost the bottom right (3rd) quadrant.

 

I'm currently at 34k, so the ring is being replaced under the original 3y/36k warranty.

I wonder if the ESP plan will cover future charge ring failures.

 

I would suspect that if it's only a light that's out on the charge port, but the charge function works correct then you would need the PremiumCare Exterior/Interior Lighting Coverage option on the ESP for it to be covered.  


Edited by bwheetley, 11 September 2016 - 06:51 AM.

1974 Mercedes 240D -> 1948 Chevy Coupe -> 1981 Mercedes 300D -> 1982 Mercedes 300TD -> 1995 Mitsubishi Galant -> 2002 Ford Explorer Sport Trac -> 2012 Infiniti M Hybrid -> 2014 Ford Fusion Energi Titanium

286179.png


#30 OFFLINE   expresspotato

expresspotato

    New Member

  • Fusion Energi Member
  • 92 posts
  • Region:Canada Atlantic Provinces
  • LocationToronto
  • Current Vehicle:2013 Ford Fusion Hybrid
  • My Fusion's Year:Decline

Posted 11 January 2018 - 02:44 PM

So I just lost the 2nd quadrant on a 2015 MY... Guess they made a crappy part... Jeeze Ford really knows how to make em cheap. Between this and my totaled 2013 it was what 15 visits to dealers?

 

Ashley doesn't seem to be active on these forums anymore for over a year, anyone have any luck under warranty outside B2B?


Edited by expresspotato, 11 January 2018 - 03:20 PM.


#31 OFFLINE   jsamp

jsamp

    New Member

  • Fusion Energi Member
  • 205 posts
  • Region:U.S. Pacific Coast
  • LocationCA
  • Current Vehicle:Fusion Energi SE, Escape Hybrid
  • My Fusion's Year:2015

Posted 12 January 2018 - 02:14 PM

Yep, my 3rd quadrant has been out for months.  I haven't had a window to get it to the dealer yet, but plan on doing so before the warranty runs out.  I did notice that at night it is barely noticeable ( ~5% brightness) but you can't see that during the day.

 

I also have a non-working lumbar support, so I'll have both done.



#32 OFFLINE   expresspotato

expresspotato

    New Member

  • Fusion Energi Member
  • 92 posts
  • Region:Canada Atlantic Provinces
  • LocationToronto
  • Current Vehicle:2013 Ford Fusion Hybrid
  • My Fusion's Year:Decline

Posted 14 January 2018 - 09:30 PM

Wondering if this is covered though. Will send an email to my SM soon and find out.



#33 OFFLINE   expresspotato

expresspotato

    New Member

  • Fusion Energi Member
  • 92 posts
  • Region:Canada Atlantic Provinces
  • LocationToronto
  • Current Vehicle:2013 Ford Fusion Hybrid
  • My Fusion's Year:Decline

Posted 15 January 2018 - 07:29 PM

Wondering if this is covered though. Will send an email to my SM soon and find out.

 

Service Manager said this isn't covered... So early. So broken.



#34 OFFLINE   murphy

murphy

    Energi Member

  • Moderators
  • PipPip
  • 1,936 posts
  • Region:U.S. Northeast
  • LocationPennsylvania
  • Current Vehicle:2013 Fusion Energi Titanium
  • My Fusion's Year:2013

Posted 16 January 2018 - 03:03 AM

My light ring was replaced under the ESP warranty for segment 2 being non-functional.



#35 OFFLINE   expresspotato

expresspotato

    New Member

  • Fusion Energi Member
  • 92 posts
  • Region:Canada Atlantic Provinces
  • LocationToronto
  • Current Vehicle:2013 Ford Fusion Hybrid
  • My Fusion's Year:Decline

Posted 17 January 2018 - 02:45 PM

Yeah should have bought ESP. Dealer wants $125 to install and its a $212 part. All in CAD of course - useless currency that it is -



#36 OFFLINE   4cylinder

4cylinder

    New Member

  • Fusion Energi Member
  • 107 posts
  • Region:U.S. Great Lakes
  • LocationMetro Detroit
  • Current Vehicle:2017 Energi Titanium
  • My Fusion's Year:2017

Posted 17 January 2018 - 06:27 PM

Yeah should have bought ESP. Dealer wants $125 to install and its a $212 part. All in CAD of course - useless currency that it is -

 

I had the ESP on my 2013 hybrid - paid $2000 CAD for it (was living in Canada then, temporarily expatriated to the US now, probably moving back to Canada by 2020). Waste of money because the car wasn't unreliable enough. The few problems I did have after the B2B expired (peeling trim in front passenger footwell, some creaking in front passenger seat) were not covered by the ESP. 2.5 years passed without any issue occurring that the ESP would've covered. I got a refund for the last 1.5 years.

 

If I had a Range Rover or BMW, an extended warranty would almost certainly pay for itself within the first year because those brands are notoriously unreliable (just google "Doug Demuro" for hilarious anecdotes). Ford, while less reliable than Japanese brands, is still heads and shoulders above the worst European brands.

 

I have a feeling that you'll still be ahead if you pay out-of-pocket to fix the charging ring light, as opposed to having paid for the ESP and having this relatively minor issue covered. I classify it as minor because while it is annoying to lose the quadrant, it doesn't affect the car's drivability or core features - you can still charge it after all.

 

Personally I would just leave it and save that few hundred, especially if the other quadrants still work which allows you to see when the car is fully charged. You also have MFM and the display in the car itself.

 

 

 

So I just bought my Fusion Energi (Used). And the charging ring worked the first time I charged it. It rained the following night, and I can tell it has something to do with the water, because its water logged inside the light ring at the bottom. When it dries out the third quadrant wants to light up. It flickers. First quadrant is dead. Car is still under 3 year bumper to bumper....but I am hesitant to take it to the dealer because it is our only car and if they take it in for a week I'll have to rent a car at $25+/- a day. I can't justify that expense for what really is a cosmetic issue. 

 

I am mildly annoyed at it though because I like the look of the ring when I unlock it...it influenced my purchase a little. 

 

First time poster here so cheers! I've been lurking for two weeks. 

 

Your dealer is not very nice... My dealer will provide the rental for free if the car is being repaired under warranty or if a recall operation is being performed. Only during normal maintenance does the rental cost money.


Edited by 4cylinder, 17 January 2018 - 06:30 PM.









0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy Terms of Service ·