Jump to content

Custom Search



Welcome to Ford Fusion Energi Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Fusion Energi Forum. You must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of the Ford Fusion Energi Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album, post images and more. . .
Click here to create an account now
 
Guest Message by DevFuse

Love your Fusion Energi? Register it in the official authorized Ford Energi Registry here.


Photo
- - - - -

MFM not updating

2017 fusion energi my ford mobile mfm

  • Please log in to reply
12 replies to this topic

#1 OFFLINE   Xilraazz

Xilraazz

    New Member

  • Fusion Energi Member
  • 7 posts
  • Region:U.S. Pacific Coast
  • LocationSanta Clarita
  • Current Vehicle:Lightning Blue Fusion Energi Titanium
  • My Fusion's Year:2017

Posted 23 July 2016 - 04:36 PM

I have a 2017 Ford Fusion Energi Titanium and MFM stopped updating a few days after I got it.  I called into support and they said to pull a fuse (which I couldn't find at the time) but now I don't remember which fuse they said to pull.

Anyone know or do I just need to call back into support?  I even took it to the dealership and they said I'd need to bring it in for service so the electrical guys could take a look.

I would prefer not to do a 12V cable pull because I don't want to lose any historical data.

Thanks.

-Tyler










Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   Xilraazz

Xilraazz

    New Member

  • Fusion Energi Member
  • 7 posts
  • Region:U.S. Pacific Coast
  • LocationSanta Clarita
  • Current Vehicle:Lightning Blue Fusion Energi Titanium
  • My Fusion's Year:2017

Posted 26 July 2016 - 03:38 PM

So it appears this also affected Go Times scheduling and Charge profiles.

I e-mailed MFM support and got back the following information, in case anyone else runs into this issue.

 

The fuse panel is located under the instrument panel to the left of the steering column (the Passenger Compartment Fuse Panel). NOTE: It may be easier to access the fuse panel if you remove the finish trim piece.  It is Fuse 10 (5 amp) which may be referred to Cell Phone Passport if you search within your owner’s guide.  

 

You can check for a diagram starting on page 249 here: http://www.fordservicecontent.com/Ford_Content/Catalog/owner_information/2017-Fusion-Hybrid-Enegi-Owners-Manual-version-1_om_EN-US_03_2016.pdf



#3 OFFLINE   Doc Rock

Doc Rock

    New Member

  • Fusion Energi Member
  • 26 posts
  • Region:U.S. Northeast
  • LocationPennsylvania
  • Current Vehicle:Fusion Energi Platinum
  • My Fusion's Year:2017

Posted 29 August 2016 - 06:11 PM

I'm having the same problem with my 2017 Fusion Energi Platinum - also at two weeks after activating MFM. Will take it to the dealer to have the system checked out. And, to have the problem documented.



#4 OFFLINE   Xilraazz

Xilraazz

    New Member

  • Fusion Energi Member
  • 7 posts
  • Region:U.S. Pacific Coast
  • LocationSanta Clarita
  • Current Vehicle:Lightning Blue Fusion Energi Titanium
  • My Fusion's Year:2017

Posted 30 August 2016 - 05:33 AM

it seems this happens when you try to connect to MFM and the car doesn't have cell service, which sucks for me, because I live in an area where there is no cell service.  It would be nice if MFM would communicate while the car is connected to WiFi.



#5 OFFLINE   My14Energi

My14Energi

    New Member

  • Fusion Energi Member
  • 109 posts
  • Region:Decline
  • LocationFlorida
  • Current Vehicle:Fusion Energi
  • My Fusion's Year:Decline

Posted 30 August 2016 - 06:32 AM

With my car i have found if you repeatedly try to connect when it has no cell signel it gets jammed up somehow and still wont connect even when you get to an area with service. I now know where it gets a signal and where it doesnt(garage) and dont try to connect there. I have pulled the fuse with success each time in resetting the cell modem only to have it get jammed trying to update in the wrong spots. Since the last reset its been working perfect. It sucks thats the way it works but for now it seems the only way to work around it.

Pull the fuse to reset first though, very easy to do

Edited by My14Energi, 30 August 2016 - 06:34 AM.


#6 OFFLINE   Doc Rock

Doc Rock

    New Member

  • Fusion Energi Member
  • 26 posts
  • Region:U.S. Northeast
  • LocationPennsylvania
  • Current Vehicle:Fusion Energi Platinum
  • My Fusion's Year:2017

Posted 01 September 2016 - 11:24 AM

Took my Energi to the dealer today. They pulled Fuse 10 (fuse was fine), the reinserted it. MyFordMobile is now up and running again on my iPhone and on the web.

 

Be advised that trying to pull the fuse yourself is not that easy. First, you have to pull down the finish trim piece under the steering wheel, then reach way back to the fuse panel to the left of the steering wheel - making sure you have located the correct fuse (it's amber and marked "5" for the amperage), then manage to pull the fuse. As my service rep remarked, the design was done by engineers who will never have to pull a fuse!


  • Sore Rider likes this

#7 OFFLINE   Doc Rock

Doc Rock

    New Member

  • Fusion Energi Member
  • 26 posts
  • Region:U.S. Northeast
  • LocationPennsylvania
  • Current Vehicle:Fusion Energi Platinum
  • My Fusion's Year:2017

Posted 01 September 2016 - 01:48 PM

Failed again! After only 2 hours! I am not a happy camper. Ford is pretending this is a problem with only my car.



#8 OFFLINE   Sore Rider

Sore Rider

    New Member

  • Fusion Energi Member
  • 1 posts
  • Region:U.S. Pacific Coast
  • LocationWashington State
  • Current Vehicle:Fusion Energi
  • My Fusion's Year:2017

Posted 07 November 2017 - 11:26 PM

2017 Fusion Titanium Energi MyFordMobile stopped updating after new Samsung Galaxy S7 Android phone system update about on 1 November 2017. Did some online research and arrived at the solution that indicates pulling (it's a triple-legged fuse) should restore MyFordMobile to it's advertised capability.  This solution was verified by my local Ford dealer.  So,if you take a small flashlight and stand on your head under the steering wheel, you needn't pull the fairly-large trim piece immediately under the steering column and risk breaking it.  While taking appropriate steps to avoid dropping the flashlight on your nose, contort and abuse your hand into position to pull Fuse 10/11 and keep it out for three to five minutes.  Then reinsert.  It's now been two days with no recurring problem; I grow more optimistic each day that the problem is now solved. 

 

Incidentally, the fuse box diagram is on page 249 of the 2017 Ford Fusion Energi Owner's Manual.  The function of the fuse is listed as "Keypad. Cell phone passport module." on page 250.  Darned if I know what that means but it apparently allows a hard reset of the system, not unlike shutting off and restarting a Windows Operating Systems every time it loses some necessary functionality.    

 

If you have a C-MAX Energi with the same problem with MyFordMobile not updating, the solution appears to be to pull and reinsert Fuse 67. 

 

Good luck!



#9 OFFLINE   murphy

murphy

    Energi Member

  • Moderators
  • PipPip
  • 1,977 posts
  • Region:U.S. Northeast
  • LocationPennsylvania
  • Current Vehicle:2013 Fusion Energi Titanium
  • My Fusion's Year:2013

Posted 08 November 2017 - 02:30 AM

It's much easier to disconnect the negative lead of the 12 volt battery to do the reset.



#10 OFFLINE   Xilraazz

Xilraazz

    New Member

  • Fusion Energi Member
  • 7 posts
  • Region:U.S. Pacific Coast
  • LocationSanta Clarita
  • Current Vehicle:Lightning Blue Fusion Energi Titanium
  • My Fusion's Year:2017

Posted 08 November 2017 - 07:08 AM

I wish they'd fix this issue with a software update or something.


Edited by Xilraazz, 08 November 2017 - 07:11 AM.


#11 OFFLINE   gfunk8888

gfunk8888

    New Member

  • Fusion Energi Member
  • 3 posts
  • Region:U.S. Mississippi Valley
  • Locationstl
  • Current Vehicle:2017 ffe ti
  • My Fusion's Year:2017

Posted 09 January 2018 - 02:51 PM

Long time follower, first time registrant/poster here. My MFM went dark for three days. I did pull fuse 10/11 (it’s a 3-legged combination fuse) for five minutes. It was not easy to access or remove. However, when I reinstalled it, I immediately started getting push notifications on my phone from failed remote starts over the past three days. All appears to be well again. Thanks!

#12 OFFLINE   Oktemplar

Oktemplar

    New Member

  • Fusion Energi Member
  • 1 posts
  • Region:Decline
  • LocationNewark, OH
  • Current Vehicle:Ford Fusion Energi
  • My Fusion's Year:2014

Posted 17 January 2018 - 01:46 PM

I wish I had seen this topic before I took my car to the dealer. We purchased our 2014 Ford Fusion Energi last summer used and have used MFM on it ever since. As of Jan 1 2018 MFM no longer updated and we couldn’t remote start etc. Took to dealer Monday, they accessed the module and told me the car has the wrong module installed (it has a 2016 sticker on it, way too new for my 2014 car). I think the module is likely a replacement from the AT&T 2G conversion. Anyway, we’re into day 3 of them looking at it and not coming up with any solutions.

I will try pulling the fuse when I get it back later. We’ve really liked our Fusion Energi so far, but this experience has soured me a bit on Ford’s approach to tech in their cars. Seems there have been a lot of similar experiences with others on this forum :(

#13 OFFLINE   Johnny Mo

Johnny Mo

    New Member

  • Fusion Energi Member
  • 34 posts
  • Region:U.S. Northeast
  • LocationWestchester County
  • Current Vehicle:Porsche Cayenne S e-hybrid, 2015 Ti-FFE
  • My Fusion's Year:2015

Posted 30 January 2018 - 05:56 AM

Mine (2015 Energi) stopped working about a week ago, and my dealer is telling me that I need to have 3 modules updated/replaced - ohhh yeah at my cost (I have ESP BTW).  So apparently FORD feels that since this is an option that I should have to pay for the upgrade, when clearly the change in modem and firmware that THEY engineered is causing my MFM to not work.  That's like saying hey we loaded this new firmware that will no longer allow you to use your heated seats unless you replace them, or your moonroof unless you replace the control panel...WTF seriouslY???   This aint over...stay tuned boys and girls, shit's about to get real.


  • ukxpat likes this









Also tagged with one or more of these keywords: 2017, fusion, energi, my ford mobile, mfm

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy Terms of Service ·