Jump to content

Custom Search



Welcome to Ford Fusion Energi Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Fusion Energi Forum. You must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of the Ford Fusion Energi Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album, post images and more. . .
Click here to create an account now
 
Guest Message by DevFuse

Love your Fusion Energi? Register it in the official authorized Ford Energi Registry here.


Photo
- - - - -

Charge light ring issue


  • Please log in to reply
7 replies to this topic

#1 OFFLINE   jsamp

jsamp

    New Member

  • Fusion Energi Member
  • 313 posts
  • Region:U.S. Pacific Coast
  • LocationCA
  • Current Vehicle:Fusion Energi SE, Escape Hybrid
  • My Fusion's Year:2015

Posted 28 August 2017 - 03:52 PM

  So when I picked up my used 2015 Energi, I didn't notice that one quadrant of the light ring was out.  It's a CPO so I can get that replaced.  What happened a couple weeks later has me baffled. 

  I was changing all sorts of settings through the touch screen, and one was the light ring settings.  It was "on" but the other option was "limited" which I selected in order to get a description of what that setting was.  After reading it and deciding I didn't want that setting, I put it back to "on".  Ever since then, it is acting as though the setting is on "limited", meaning it won't light up while charging to indicate how full the charge is.  It just blinks briefly when plugging in and that's it.  I've changed it several times but it doesn't act accordingly.

I even tried "reset to factory settings" (which eliminated all the settings I had changed) but it still acts the same.  It is set to "on" but doesn't act that way.

 

Similarly, no matter what I select, I can't get the backup "beeping" to go silent (has backup camera).  Which setting is supposed to turn that off?

 

Any other suggestions?  Any similar experiences?










Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   Timewellspent

Timewellspent

    New Member

  • Fusion Energi Member
  • 281 posts
  • Region:U.S. Northern Plains
  • LocationMN
  • Current Vehicle:Fusion Energi
  • My Fusion's Year:2015

Posted 29 August 2017 - 08:21 AM

Do you have value charge setup?  It will cycle the 4 quads and go out until it starts to charge.  As far as the beeping.  When I put my car in reverse, the left screen pops up with "Rear park aid" on/off  and can turn this off at that time.  Otherwise I'm sure it is in the settings on that left display for you to turn that on/off.


409947.png


#3 OFFLINE   jsamp

jsamp

    New Member

  • Fusion Energi Member
  • 313 posts
  • Region:U.S. Pacific Coast
  • LocationCA
  • Current Vehicle:Fusion Energi SE, Escape Hybrid
  • My Fusion's Year:2015

Posted 29 August 2017 - 11:38 AM

No, I do not have value charging on.  It was working fine before (light ring cycled twice around before indicating charging).

 

Left screen is where I've been turning off the backup beeper, but it seems to turn itself back on each time I start the car.  I'll have to read more in the manual to see if there is a way to permanently turn it off.



#4 OFFLINE   jgrockwell

jgrockwell

    New Member

  • Fusion Energi Member
  • 1 posts
  • Region:U.S. Southern
  • LocationMelbourne
  • Current Vehicle:Energi
  • My Fusion's Year:2015

Posted 06 October 2017 - 06:11 AM

Im having the same problem. I also notice that when the ring light goes out that the charging exhaust fan decreases in its intensity. I am hopeful someone on this forum with some knowledge of the issue can weigh in. 



#5 OFFLINE   Davidoo

Davidoo

    New Member

  • Fusion Energi Member
  • 42 posts
  • Region:U.S. Pacific Coast
  • LocationPhoenix
  • Current Vehicle:2017 Energi
  • My Fusion's Year:2017

Posted 06 October 2017 - 03:02 PM

When mine charges and it gets full, the ring light will go out and you can hear the fan decrease as well.  However, the light on the charger is still blinking.  I was told by the dealer that this means it is now charging the 12 volt battery in the trunk, and you should leave it plugged in until all the charging is finished.



#6 OFFLINE   jsamp

jsamp

    New Member

  • Fusion Energi Member
  • 313 posts
  • Region:U.S. Pacific Coast
  • LocationCA
  • Current Vehicle:Fusion Energi SE, Escape Hybrid
  • My Fusion's Year:2015

Posted 20 November 2017 - 11:04 AM

UPDATE:

 

So a couple of days ago when I plugged in, the light ring did it's cycle (2x around) and was acting correctly.  I didn't change a single setting, I just plugged it in.  Can't for the life of my figure out why it stopped working a couple months ago, then suddenly started working again the other day.  So far it's been 3-4 days and it is working right.

 

Now I probably jinxed it.



#7 OFFLINE   EVRMODE

EVRMODE

    New Member

  • Fusion Energi Member
  • 5 posts
  • Region:U.S. Northeast
  • LocationMassachusetts
  • Current Vehicle:Ford Fusion Energi
  • My Fusion's Year:2014

Posted 18 December 2018 - 11:51 AM

My 2014 Ford Fusion Energi has the flashing ring since 76k. First Ford dealer said it was my charger. They didn't know the first thing about the car. The next Ford dealer was a hybrid certified garage. First visit they said charging port needs to be replaced. I replaced it. Still not working. Brought it back, now they're guessing the SOBDM. I've taken 3 days off and $204 for diagnosis. Guess what brand I'm not going to buy my next electric car from.

#8 OFFLINE   EVRMODE

EVRMODE

    New Member

  • Fusion Energi Member
  • 5 posts
  • Region:U.S. Northeast
  • LocationMassachusetts
  • Current Vehicle:Ford Fusion Energi
  • My Fusion's Year:2014

Posted 21 January 2019 - 04:41 AM

So I messaged Ford customer service department. They asked me if I would like to try the dealer again for a third time. Otherwise she said she sent me a link for additional Ford dealers. Not very helpful.








0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy Terms of Service ·